This is archived content. Visit our new forum.
  • Author
  • #855748


    Be advised that versions of PHP older than 5.5 are “end of life”. This means that the PHP developers no longer support it, and it is a potential security risk.

    As does WordPress, we strongly recommend that you use supported versions of PHP (v5.5, v5.6, and v7) as this will keep your site the most stable and secure.

    Most hosts will allow you to easily change the version of PHP used for your site. Here are a list of articles we’ve found from hosts that are known to use outdated PHP versions, and how to update them.


    If your host is not listed here, you can try contacting them:

    Please update the PHP version used on my site to at least 5.5, preferably the latest available version.

    If your host is unwilling to use a supported version of PHP, our recommendation at that point would simply be to consider switching hosts (and of course with Themeco Hosting you’ll have nothing to worry about.)

    We fully support WordPress, and will continue to update things in accordance with PHP 5.2 compatibility, but have seen on occasion some PHP version related issues slip through our internal testing and even extensive testing done by our beta group. We will certainly fix anything that arrises, and apologize for any inconvenience caused by these edge cases. With the PHP version market share of these end of life versions dwindling, we would highly recommend you update any outdated sites as soon as possible.