Release Notes - Pro 2.4, X 6.4, Cornerstone 3.4

Our feature request release is live! This is primarily a maintenance release including significant builder speed improvements! This post will include all important news, any confirmed issues, and a timeline of events related to this cycle. Please be sure to always start by reading the Changelog.

Status Report

  • 12/28 - X 6.4.6, Pro 2.4.6, and Cornerstone 3.4.6 available via automatic updates (final release of this cycle).
  • 12/24 - X 6.4.5, Pro 2.4.5, and Cornerstone 3.4.5 available via automatic updates.
  • 12/20 - X 6.4.4, Pro 2.4.4, and Cornerstone 3.4.4 available via automatic updates.
  • 12/19 - X 6.4.3, Pro 2.4.3, and Cornerstone 3.4.3 available via automatic updates.
  • 12/17 - X 6.4.2, Pro 2.4.2, and Cornerstone 3.4.2 available via automatic updates.
  • 12/14 - X 6.4.1, Pro 2.4.1, and Cornerstone 3.4.1 available via automatic updates.
  • 12/12 - Initial release. X 6.4.0, Pro 2.4.0, and Cornerstone 3.4.0 available via automatic updates.
  • 12/12 - Initial release. X 6.4.0, Pro 2.4.0, and Cornerstone 3.4.0 available via manual updates.

Confirmed Issues

The following issues are specific to this cycle. If listed here we are planning to address it in a subsequent point release. Notations will be added when items are fixed. For a complete list of what’s changed to date with this cycle see the Changelog.

  • Inspector controls that are unitless values (notably line height) don’t update correctly. Fixed in first point release.
  • Unable to clear the text field of a color picker. Fixed in second point release.
  • Pressing tab while in the “class” input causes preview to shift to the left and becomes inaccessible. Fixed in second point release.
  • Incorrect label when confirming if you want to apply a preset. Fixed in second point release.
  • Select options in horizontal inspector flow outside the control dimensions. Fixed in second point release.
  • Attempting to add a preview image to a template will navigate away from the application to the home page. Fixed in third point release.
  • Font Weight selection shows HTML entity instead of correct character. Fixed in third point release.
  • Dragging color picker opacity makes preview unselectable. Fixed in third point release.
  • Deleting leading number in unit input pushes cursor to the end. Fixed in third point release.
  • Resetting the color picker doesn’t set it to “transparent”. This has adverse side effects like the “Interaction” color control hiding. Fixed in fourth point release.
  • vh/vw unit types missing from some padding and margin controls. Fixed in fifth point release.
  • If you updated to WordPress 5.0.2, Gutenburg now hides the post format options Fixed in fifth point release.
  • Yoast SEO Analyzer is blank if you are using the classic editor. Fixed in sixth point release.

FAQ

<strong>When is the release to automatic updates?</strong>

Our product releases are done in phases. You can download the latest version from your dashboard page. The downloads can be used for manually updating or setting up a new install. Automatic updates will be available some time after the initial release. This process helps us provide better support and catch potential lingering issues that were not uncovered in beta testing. You can find instructions to manually update in this knowledge base article.

<strong>What's the deal with Gutenburg?</strong>

X, Pro, and Cornerstone are fully compatible with the WordPress 5.0 update. For more info on Gutenburg, see this article: https://theme.co/apex/forum/t/gutenberg-faq/40776

<strong>Why do my Visual Composer rows and columns look broken after this update?</strong>

Go to WPBakery Page Builder Settings > General and make sure “Legacy X Integration” is enabled. A common request we get is to not overwrite parts of the WPBakery Page Builder. We are committed to keep supporting sites from the early days of X where Visual Composer was our page builder but we’ve consolidated all that integration code under one setting. It used to be enabled by default, but you will now need to opt-in to use it.