Font Manager not loading Adobe fonts- refreshing forever

I get my webfonts from Adobe Fonts/Typekit. All the fonts in my kit load without a problem in the Typekit plugin (Pro/Typekit) and they appear in the Kit information but when I go to Font Manager and try to refresh the fonts using the exact same Typekit ID the fonts don’t load and Font manager refreshes forever. I reinstalled the theme but the problem persists. Could you help? Thanks

1 Like

Hi There,

Thank you for writing in, please do the following:

  • Ensure that you are fully up to date. WordPress, Theme, and Cornerstone (Version Compatibility)

  • Clear all the site caches (plugin, server-side, CDN, and browser’s cache) so that the code from the latest release is always in use. This will help you to avoid any potential errors. While you’re at it, please deactivate this caching feature while we tackle this issue.

  • Test for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

  • Contact your hosting provider to increase your allocated memory limit or do it yourself by adding this code in your wp-config.php file.

define( 'WP_MEMORY_LIMIT', '512M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

You can add it before the line:

/* That’s all, stop editing! Happy blogging. */

[Increasing PHP Memory Limit](

After doing all this and if the issue persists, please provide us the site URL and credentials in a **[Secure Note](** so we can take a closer look.


Many thanks for your reply. I’ve tried all your suggestions to no avail. I uninstalled all the plugins apart from Typekit and Woocommerce, checked that I have all the latest versions and I also added those two lines of code to wp-config.php file. I’m building a website locally, using WAMP and am using Typekit for webfonts. So far, this setup hadn’t caused any problem. At the moment, I’m able to successfully import webfonts via the Typekit plugin (attached image), BUT when I try to import via Font Manager (using the same kit ID) it keeps refreshing forever (attached image). The funny thing is that the exact same problem occurs with a different computer that I use at home. I also tried to import custom fonts from my desktop and it works fine. A couple of days ago Adobe changed Typekit, which now is known as “Adobe Fonts” and they’ve slightly simplified the interface. Could this problem have to do with this change? By the way, are we supposed to use the Typekit plugin at the same time of Font Manager? Is the plugin necessary for Font manager to work or could I import Adove webfonts directly into Font Manager, ignoring the Typekit plugin altogether?
Thanks for your help

Hi There,

Since you’re working on a localhost would you mind sharing your Typekit Kit ID in a secure note so we can test it on our end.

The Typekit plugin is not necessary, you can input your Typekit Kit ID directly on the Font Manager.


Hi and thanks for your help. I`ve just saved a secure note with my Typekit id. Thanks, Gianluca

I’m seeing this as well. Perhaps something to do with the Adobe update + API, etc.

Thanks for your reply. So, basically at the moment we can’t use Font Manager with Adobe Fonts, is that correct? The thing is that all the fonts in my kit show up when I import them via the Typekit plugin included in Pro and using the exact same id…isn’t that an indication that the Adobe API+update is not the culprit? Thanks in advance for your help.

Hi @radiogiurgi,

Thanks for sharing your ID, our apologies for the inconvenience. I can confirm this bug and add to our issue tracker, so the developers will be made aware of it

Thank you for your patience.

Hi, ok, thanks for confirming. When do you expect this to be resolved? Any idea?

Hi There @radiogiurgi

I can confirm that, this issue has been added to our issue tracker. Regretfully, we cannot provide any ETA or guarantee whether this particular issue is going to be fixed within next update.

Thanks for understanding!

Could you suggest an alternative way to import webfonts from Adobe Fonts? Not being able to use Typekit webfonts is a pretty serious problem and am sure I’m not the only one affected, so it’d be of great help if you could suggest a workaround. Thanks in advance for your help,g

Adobe has a lot of documentation of how to install it manually—you can do it either through functions.php (child theme) or through your global CSS sheet. It’s a pretty simple operation.

BUT you won’t get the fonts in your font manager and you’ll need to overwrite all CSS in the global CSS file. I’ve done it before when I had an issue with Font Manager back when X first introduced it and it hiccupped on me. It’s not terrible, but doesn’t have the slickness of the Font Manager.

Ok, thanks for your message

Hi @radiogiurgi,

Would you mind doing the suggestion provided here and see if that resolves the issue?


Hi @friech,
I’m confused: you mean importing the Typekit fonts through Font Manager under Pro -> Theme Options -> Settings -> Fonts? That’s exactly what I’ve been trying to do over the past few days but font manager keeps refreshing forever and doesn’t import the fonts. I thought this had been identified as a bug already…

Hi There,

Sorry for not being clear, I was referring to this instruction by another user.

Try to republish your kit.


Hi @friech,
Typekit has changed, it’s part of Adobe Fonts now, users don’t need to publish their kits anymore, you just save your web project. Also, you are no longer required to set the list of domain names for your fonts. I’ve exchanged emails with the Adobe support team and confirmed that, apart from the changes above, there haven’t been any changes to the Typekit API, they’ve just rebranded to Adobe Fonts. This problem started the day of the change…

Hi @radiogiurgi,

Thanks for that confirmation, rest assured that this has already in the attention of our Dev Team as a lot of users getting affected by it.

You can check our changelog page when we release an update to see if a fix for this bug is included.


Hi everyone,

We’ve released a fix for this issue in today’s update. The problem is that Adobe Fonts recently changed some security settings on their API and requests made directly by our web application were failing. We were able to make some adjustments and perform the API call through the web server (your site). This is more stable in terms of getting a connection to Adobe Fonts, but it could potentially still fail if your server has a firewall that blocks outgoing connections.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.