Editing Menus very slow - hangs

I’ve seen several topics started on this, with all just saying we need to increase memory, but that isn’t the right way to solve a problem. The right way is to fix the problem in the code. :slight_smile:

I manage my own hosting (Digital Ocean) and can set everything up the way I want it. I already have the server set up for 512M of memory and this doesn’t help at all. I’m not running out of memory on the server, nor is there a heavy server load. The problem is when cornerstone is activated, you pretty much can’t access ANY menu item. You click the down arrow to edit or delete it and nothing happens for quite a while. It just hangs there. Same for trying to add a new item.

It was mentioned that some of the options on the menu are something that Cornerstone allows, but I have no clue what those do or how to use them Was there something somewhere that explained it? Is there a way to simply turn those options completely OFF so you’re not doing all those database calls while you’re trying to edit your menus? I mean, if I don’t want or need those options, I should be able to remove them.

Is there something I could add into the functions.php file to remove the options? It’s not practical to deactivate Cornerstone just to make edits to your menu! Wow, crazy.

Hello @geekgoddess,

Thanks for reaching out. :slight_smile:

Please try out following solutions and let us know the outcome:

  1. Please make sure that you are sing the latest version of X Theme and Cornerstone or Pro Theme and WordPress.
  2. Test for a plugin conflict. You can do this by deactivating all third-party plugins, and see if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

If you still have problems kindly get back to us with the result of the steps above and URL/User/Pass of your WordPress dashboard using the Secure Note functionality of the post to follow up the case.

Thank you.

Yes, of course I tested this. As others have said, they can turn off everything and it still persists. The only thing that fixes it is to deactivate Cornerstone.

As I asked, is there something I can add into the functions to turn this OFF. I don’t want these options since they are slowing down many of my client’s sites.

Also, just a general question…I NEVER get notified when I get an answer to something in the forum. How do I get notified of these responses?? The only way I know if something has been answered is to log in every day, SEARCH for my post, then see if there has been a response. Am I missing a setting somewhere that sets it up to notify me?

Hi @geekgoddess,

I can not replicate this issue on my end even with plenty of menu items. The credentials you provided above did not work, please check so we can take a closer look.

In the meantime, please update X and Cornerstone to the latest version (6.5.5 and 3.5.4 respectively)

Updating Your Themes and Plugins

Thanks,

Sorry about the wrong credentials. I’ll paste the correct ones in a private note.

Could you please let me know how I can get notified when this support ticket gets a reply?

Hi @geekgoddess,

Thank you for the credentials, but I can’t replicate the issue on your site (please see screencast below), the menu panel works just fine on my end.

Would you mind try using the incognito/private mode of your browser where there are no caching and browser add-ons involve?

Thanks,

Hi, I ran a test in incognito mode and the problem went away! So, I methodically removed extensions from Chrome until I found what was causing the slow-down. It’s LastPass, which of course, I don’t want to remove permanently. It’s also highly used, so I would imagine this issue is happening for quite a few of your users.

It’s obviously conflicting with what Cornerstone is adding to the menu options, as I’m not seeing a similar conflict or problem with LastPass on websites I manage that use a theme other than X. It’s ONLY on the sites that use X that I’m seeing this issue. Are you able to test with the LastPass plugin/extension activated?

Also, could you please answer my question on how to get notified of response to this thread? thank you!

Hi @geekgoddess,

Regretfully, there is nothing we can do about LastPass since that is a browser add-on and not part of the Wordpress eco system, what we can only advise is to disable that addon each time you work with menus.

Regarding the notification, please navigate to your Profile page > Preferences > Emails and tick the Send me an email when someone quotes me, replies to my post, mentions my @username, or invites me to a topic box.



Thank you for understanding,

I understand. I’ve opened a ticket up with LastPass, but haven’t heard anything yet. This is a major browser add-on though, so perhaps you might re-evaluate addressing the issue since it has to do with the extra fields cornerstone has added. One thing that would solve it would be to have those boxes added OPTIONALLY. If you could provide a setting to remove them (generally that’s something that would be in the settings section at the top of the WordPress admin page (the slide down bar), then it would be fixed. I’m sure I’m not the only person that doesn’t use that at all, and from my understanding it causes extra queries to the database every time you’re on the menu page.

Also, thank you for showing me where to change the settings to receive an email. I couldn’t find that! Appreciate it! :slight_smile:

You are most welcome. :slight_smile:

I wanted to pass on what I heard from LastPass support. They told me they are aware of this issue and have had several reports of it and are actively working on a fix for it now. They don’t have an ETA as to when it will be corrected, but it’s with their development team now.

Wanted to post this here in case someone else has the same issue and finds this thread.

Thanks for sharing, @geekgoddess.

In case you’d want to try temporarily removing the menu options, please see https://theme.co/apex/forum/t/x-menu-js-error/39960/15?u=christian_y

Thanks.

Thanks for pointing out that thread! I also forgot to mention that an easier workaround is to turn off the automatic functionality of the LastPass browser plugin to auto-fill every page. If you change it to “When You Click the Extension”, you will have to click the icon to make it fill in the info. Because it’s no longer automatically looking to fill in those fields once you have that selected, the issue with Cornerstone adding extra fields goes away. You can access these options by right-clicking on the browser add-on icon.

Thank you for sharing more details.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.